Author: Chris Cotter
Date: 2023-01-10T17:37:19Z
New Revision: 9fff1ddb560cbb14ba661af2c33b768f3071be9a

URL: 
https://github.com/llvm/llvm-project/commit/9fff1ddb560cbb14ba661af2c33b768f3071be9a
DIFF: 
https://github.com/llvm/llvm-project/commit/9fff1ddb560cbb14ba661af2c33b768f3071be9a.diff

LOG: [NFC] [clang-tools-extra] Alphabetize clang-tidy release notes

Alphabetize order of clang-tidy release notes, and fix `:doc:` link.

Reviewed By: Eugene.Zelenko

Differential Revision: https://reviews.llvm.org/D141391

Added: 
    

Modified: 
    clang-tools-extra/docs/ReleaseNotes.rst

Removed: 
    


################################################################################
diff  --git a/clang-tools-extra/docs/ReleaseNotes.rst 
b/clang-tools-extra/docs/ReleaseNotes.rst
index 70d26dbe42d67..a9fcc5a208bd8 100644
--- a/clang-tools-extra/docs/ReleaseNotes.rst
+++ b/clang-tools-extra/docs/ReleaseNotes.rst
@@ -167,6 +167,16 @@ Changes in existing checks
   <clang-tidy/checks/google/objc-avoid-throwing-exception>` check for 
exceptions
   thrown by code emitted from macros in system headers.
 
+- Improved :doc:`misc-redundant-expression 
<clang-tidy/checks/misc/redundant-expression>`
+  check.
+
+  The check now skips concept definitions since redundant expressions still 
make sense
+  inside them.
+
+- Improved :doc:`modernize-loop-convert 
<clang-tidy/checks/modernize/loop-convert>`
+  to check for container functions ``begin``/``end`` etc on base classes of 
the container
+  type, instead of only as direct members of the container type itself.
+
 - Improved :doc:`modernize-use-emplace 
<clang-tidy/checks/modernize/use-emplace>`
   check.
 
@@ -206,20 +216,10 @@ Changes in existing checks
   <clang-tidy/checks/readability/const-return-type>` to not
   warn about `const` value parameters of declarations inside macros.
 
-- Improved :doc:`misc-redundant-expression 
<clang-tidy/checks/misc/redundant-expression>`
-  check.
-
-  The check now skips concept definitions since redundant expressions still 
make sense
-  inside them.
-
 - Support removing ``c_str`` calls from ``std::string_view`` constructor calls 
in
-  :doc: `readability-redundant-string-cstr 
<clang-tidy/checks/readability/redundant-string-cstr>`
+  :doc:`readability-redundant-string-cstr 
<clang-tidy/checks/readability/redundant-string-cstr>`
   check.
 
-- Improved :doc:`modernize-loop-convert 
<clang-tidy/checks/modernize/loop-convert>`
-  to check for container functions ``begin``/``end`` etc on base classes of 
the container
-  type, instead of only as direct members of the container type itself.
-
 Removed checks
 ^^^^^^^^^^^^^^
 


        
_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to