aaron.ballman added a comment. In D131346#3706216 <https://reviews.llvm.org/D131346#3706216>, @nemanjai wrote:
> Why? There are many years of precedent for using `LLVM_FALLTHROUGH` and it is > very clear and obvious. What do we gain by getting rid of it? Less novel macro usage helps readability, but it's a very minor gain IMO. > Don't get me wrong, I am not super opposed to using a standard string instead > of an LLVM-specific macro. However, it seems that this leaves us with a > mixture of the macro and the standard attribute. If we are ready to replace > all occurrences in all projects and get rid of the macro altogether (with > some warning to downstream users), that seems reasonable. Replacing only some > of them seems worse than what we now have. FWIW, I was presuming that @MaskRay was removing *all* uses of the macro with the intent to remove it from Compiler.h when the last in-tree use is removed. I agree that only doing this for part of the project would have rather limited benefits. As for a downstream warning; we don't typically give much notice for other API changes, so I don't see it as being *super* critical, but it would certainly be a kindness to give folks a heads up before removing the macro. One thing we could consider doing is using `#pragma clang deprecated(LLVM_FALLTHROUGH, "use [[fallthrough]] instead")` in Compiler.h while the macro still exists to alert people doing self-builds that the change is coming. It won't help everyone, but it might help some folks? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D131346/new/ https://reviews.llvm.org/D131346 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits