cor3ntin added inline comments.
================ Comment at: clang/include/clang/AST/Expr.h:1789-1886 + enum StringKind { Ordinary, Wide, UTF8, UTF16, UTF32 }; private: unsigned numTrailingObjects(OverloadToken<unsigned>) const { return 1; } unsigned numTrailingObjects(OverloadToken<SourceLocation>) const { return getNumConcatenated(); } ---------------- aaron.ballman wrote: > I like the idea of renaming both of these -- `isASCII()` can be a bit > confusing with `containsNonAscii()` as well. However, instead of "ordinary", > would it make more sense to go with "narrow" as the term of art? That also > goes nicely with the use of "wide" in this interface. narrow encompass ordinary and `u8` literals in standard terminology. And, I think `narrow` is too easilly mistaken as a synonym for `getByteLength() == 1` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D128762/new/ https://reviews.llvm.org/D128762 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits