djasper added inline comments. ================ Comment at: include-fixer/IncludeFixer.cpp:166 @@ -159,1 +165,3 @@ QueryString = ExtendNestedNameSpecifier(Range); + SymbolRange = tooling::Range(SM.getDecomposedLoc(Range.getBegin()).second, + QueryString.size()); ---------------- Lots of code duplication. Maybe pull out function/lambda?
================ Comment at: include-fixer/IncludeFixer.cpp:259 @@ +258,3 @@ + // Query the symbol based on C++ name Lookup rules. + // Firstly, lookup the identifier with scoped namespace contexts; If fails, + // falls back to look up the identifier directly. ---------------- "If that fails, .." ================ Comment at: unittests/include-fixer/IncludeFixerTest.cpp:144 @@ -141,1 +143,3 @@ + runIncludeFixer("a::b::foo bar;\n", + /*FixNamespaceQualifiers=*/true, IncludePath)); ---------------- I think we should set this to true everywhere or more precisely completely remove this parameter. Now that the flag is gone, we are starting to test implementation details IMO. http://reviews.llvm.org/D21603 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits