python3kgae marked 2 inline comments as done. python3kgae added inline comments.
================ Comment at: clang/include/clang/Driver/Options.td:6765 "as_6_5, as_6_6, as_6_7">; +def fcgl : DXCFlag<"fcgl">, + HelpText<"Generate high-level code only. Without any dxil related passes.">; ---------------- aaron.ballman wrote: > beanz wrote: > > aaron.ballman wrote: > > > Any particular reason for this name? Naively, I have no idea what this > > > does or how it relates to code generation. > > I have no idea what this name is short for… code gen language?… likeness?… > > lobotomy?… > > > > We have this flag in DXC, and it is a useful shorthand. > > > > Don’t know if @python3kgae or @pow2clk know what the actual abbreviation is. > Can we pick a more descriptive name, or would that make portability too much > of a challenge? Could we have a more descriptive name and then have `-fcgl` > be an alias for it, or is that overkill because this is a rarely-used option? Sure. I'll add a more descriptive name and alias fcgl to it. It is something like frontend codeGen listing if I remember correctly. ================ Comment at: clang/unittests/Driver/ToolChainTest.cpp:613 +TEST(DxcModeTest, ValidatorFCGL) { + IntrusiveRefCntPtr<DiagnosticIDs> DiagID(new DiagnosticIDs()); ---------------- aaron.ballman wrote: > Any reason not to use the typical lit tests for this? It seems like you > should be able to add a Driver test that does `-###` and looks for the > expected pass-down flags. And then you can add a -cc1 test to ensure that the > `-fcgl` flag isn't supported there. I'll use -### to add a lit test. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D124983/new/ https://reviews.llvm.org/D124983 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits