Meinersbur marked 7 inline comments as done. Meinersbur added inline comments.
================ Comment at: llvm/include/llvm/Frontend/OpenMP/OMPConstants.h:135 + UnorderedGuidedSimd = BaseGuidedSimd | ModifierUnordered, // (46) + UnorderedRuntimeSimd = BaseRuntimeSimd | ModifierUnordered, // (47) + ---------------- peixin wrote: > Why not using the following to be consistent with the name in kmp.h? > StaticBalancedChunked > GuidedSimd > RuntimeSimd As mentioned in the summary. to avoid confusion by not using the original name. `StaticBalancedChunked` could mean either the algorithm to use (now `BaseStaticBalancedChunked`, as in `omp_sched_t`/`enum kmp_sched`), or that algorithm with the unordered flag set (now `UnorderedStaticBalancedChunked `). I would the former because that's how the enum is structured. The name in `kmp.h` for it is actually `kmp_sch_static_balanced_chunked`. `sch` for "unordered"? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D123403/new/ https://reviews.llvm.org/D123403 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits