amyk added inline comments.

================
Comment at: llvm/lib/Target/PowerPC/PPCMIPeephole.cpp:432
       if (EnableTrapOptimization && TrapOpt) {
+        bool IsVReg =
+            (MI.getNumOperands() && MI.getOperand(0).isReg())
----------------
amyk wrote:
> Might be good to pull out `MI.getOperand(0).isReg()` into a separate variable 
> since you're using it three times here. 
I think you can disregard my comment. I realized later that there are both 
`isReg()` and `getReg()`, and the latter should be called only when `isReg()` 
is true. Sorry about that.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D117355/new/

https://reviews.llvm.org/D117355

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to