Anastasia added a comment.

Just to understand the intent - is this a performance optimization or 
functionality fix?

Also is there any way to test this?



================
Comment at: clang/lib/CodeGen/CGOpenCLRuntime.h:42
   llvm::PointerType *SamplerTy;
+  llvm::StringMap<llvm::PointerType *> Tys;
 
----------------
Maybe it can be named CachedTys?


================
Comment at: clang/lib/CodeGen/CGOpenCLRuntime.h:55
                                   llvm::Type *&PipeTy);
+  llvm::PointerType *getType(const Type *T, StringRef Name);
 
----------------
getType -> getPointerType ?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D119011/new/

https://reviews.llvm.org/D119011

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to