njames93 added inline comments.
================ Comment at: clang-tools-extra/clangd/Selection.cpp:194 + return Tok.kind() == tok::comment || Tok.kind() == tok::semi || + Tok.kind() == tok::kw_const || Tok.kind() == tok::kw_volatile || + Tok.kind() == tok::kw_restrict; ---------------- Just a drive by comment. This looks like it should be refactored to a switch just to make it more readable. Or if `syntax::Token` supports `isOneOf` method like `clang::Token`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D117185/new/ https://reviews.llvm.org/D117185 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits