Quuxplusone added inline comments.
================ Comment at: clang/unittests/Format/FormatTest.cpp:22727 + +TEST_F(FormatTest, CoRoutineawait) { + verifyFormat("int x = co_await foo();"); ---------------- MyDeveloperDay wrote: > Quuxplusone wrote: > > > naming of the tests is to allow easy running of all CoRoutine tests > > `./FormatTests --gtest_filter=*CoRoutine*` That's a good rationale for consistency, but the English/C++ word is still "coroutine", not "CoRoutine." If there are other places that need changing, maybe it makes sense to mass-rename in a separate commit. The main thing I'm saying is "CoRoutine" is universally wrong. :) (I also don't see why `*Coroutine*` should be a more useful dimension to want to filter on, than `*Cpp20*` or `*Keywords*` or `*Unary*` or whatever. I'd also be surprised if clang-format's tests ever run slow enough that filtering is //desired//. But I don't know and will defer to you-or-whoever.) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D114859/new/ https://reviews.llvm.org/D114859 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits