craig.topper added inline comments.
================ Comment at: llvm/lib/Target/RISCV/RISCV.td:224 + +def HasStdExtVIntegerEEW32 + : Predicate<"Subtarget->hasStdExtV() || SubTarget->hasStdExtZve32x()">, ---------------- Can we add the AssemblerPredicate to HasVInstructions and use that? Or we can rename it to HasVInstructionsAnyInt? Similar for HasStdExtZveFloating and HasVInstructionsAnyF. And maybe rename HasStdExtVIntegerEEW64 to something like HasVInstructionsEEW64? I'd like to avoid using the term "StdExt" in the name for something that isn't truly an extension name. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D112408/new/ https://reviews.llvm.org/D112408 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits