hokein marked 2 inline comments as done. ================ Comment at: clang-tidy/misc/UnusedUsingDeclsCheck.cpp:59 @@ -59,1 +58,3 @@ /*SkipTrailingWhitespaceAndNewLine=*/true)); + for (const auto It : Using->shadows()) { + const auto *TargetDecl = It->getTargetDecl()->getCanonicalDecl(); ---------------- alexfh wrote: > It's not iterator, so `It` is a confusing name. Something along the lines of > `Shadow` or `UsingShadow` should be better. Actually, the `Using->shadows()` returns an iterator range, but I'm fine renaming it here.
http://reviews.llvm.org/D20429 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits