rnk added inline comments.

================
Comment at: llvm/lib/Support/Path.cpp:1295
   SmallString<128> ResultPath;
-  if (std::error_code EC =
-          createUniqueFile(Model, FD, ResultPath, OF_Delete, Mode))
+  if (std::error_code EC = createUniqueFile(Model, FD, ResultPath, Flags, 
Mode))
     return errorCodeToError(EC);
----------------
abhina.sreeskantharajan wrote:
> rnk wrote:
> > Instead of requiring the caller to add `OF_Delete`, I think it would be 
> > better to pass `OF_Delete | Flags` here.
> Sure, I'll make that change. Do you think we should change the name to 
> "ExtraFlags" to indicate there is a default, or is the current name is fine?
That seems reasonable to me, I like `ExtraFlags`.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D103806/new/

https://reviews.llvm.org/D103806

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to