vsavchenko marked an inline comment as done.
vsavchenko added inline comments.


================
Comment at: 
clang/include/clang/StaticAnalyzer/Core/BugReporter/BugReporterVisitors.h:231
+  template <class ExpressionHandlerType, class... Args>
+  void addExpressionHandlerToTheTop(Args &&... ConstructorArgs) {
+    addExpressionHandlerToTheTop(std::make_unique<ExpressionHandlerType>(
----------------
vsavchenko wrote:
> martong wrote:
> > This naming is a bit too bloated to me, what do you think about this:
> > ```
> > enum class Position { Front, Back };
> > addExpressionHandler(Front, ...) {
> > ```
> Maybe `addHighPriorityHandler` and `addLowPriorityHandler`? There is probably 
> no reason to put `Expression` and `Store` into the actual name.
What do you think about this solution?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D103605/new/

https://reviews.llvm.org/D103605

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to