yonghong-song added inline comments.
================ Comment at: clang/lib/CodeGen/CGExpr.cpp:2840 + // Emit debuginfo for the function declaration if the target wants to. + if (getContext().getTargetInfo().allowDebugInfoForExternalVar()) { + CGDebugInfo *DI = CGM.getModuleDebugInfo(); ---------------- dblaikie wrote: > Seems like this should be renamed given it's being used for things other than > external variables? I noticed this but didn't change it as I thought the current name is *sort of* okay. But you are right. It is not precise. Will change to "allowDebugInfoForExternalRef()" and resubmit. Let me know if you have better function name suggestion. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D100567/new/ https://reviews.llvm.org/D100567 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits