aeubanks added a comment. I'm not sure that having a helper method with 4 lambdas is any cleaner. Normal control flow in a function is easier to read and understand, and not really that much more code.
================ Comment at: llvm/lib/Passes/StandardInstrumentations.cpp:222 if (any_isa<const Loop *>(IR)) { const Loop *L = any_cast<const Loop *>(IR); ---------------- jamieschmeiser wrote: > This could be changed to an assert and then the llvm_unreachable can be > removed. I kinda prefer the symmetry. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D100231/new/ https://reviews.llvm.org/D100231 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits