njames93 added a comment.

Not strictly relevant here, but this does open up the idea of enforcing the 
style where an enum constant is prefixed by the initials of the enum name.



================
Comment at: 
clang-tools-extra/test/clang-tidy/checkers/readability-identifier-naming-hungarian-notation.cpp:25
+// RUN:     {key: readability-identifier-naming.FunctionCase       , value: 
CamelCase },           \
+// RUN:     {key: readability-identifier-naming.ClassCase          , value: 
szHungarianNotation }, \
+// RUN:     {key: readability-identifier-naming.TypedefCase        , value: 
szHungarianNotation }, \
----------------
Class names shouldn't use hungarian notation.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D86671/new/

https://reviews.llvm.org/D86671

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to