rsmith added a subscriber: rsmith. ================ Comment at: test/clang-tidy/readability-redundant-inline.cpp:5 @@ +4,3 @@ + inline int f1() { +// CHECK-MESSAGES: :[[@LINE-1]]:14: warning: 'inline' is redundant because method body is defined inside class [readability-redundant-inline] +// CHECK-FIXES: {{^}} int f1() ---------------- The `inline` keyword here is not actually redundant to Clang -- we generate an LLVM `inlinehint` if `inline` is specified here and not otherwise.
http://reviews.llvm.org/D18914 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits