eduucaldas added inline comments.
================ Comment at: clang/unittests/Tooling/Syntax/TreeTest.cpp:1005 + +TEST_P(SyntaxTreeTest, QualifiedIdWithNamespace) { + if (!GetParam().isCXX()) { ---------------- Here I didn't merely split the tests, I also changed them a bit. PTAL. ================ Comment at: clang/unittests/Tooling/Syntax/TreeTest.cpp:1546-1548 +unsigned operator "" _r(const char*); +template <char...> +unsigned operator "" _t(); ---------------- Same setup for `FloatUserDefinedLiteral`. I think it is justified with the Annotations we can constraint the dump just to the expressions being tested ================ Comment at: clang/unittests/Tooling/Syntax/TreeTest.cpp:635 -TEST_P(SyntaxTreeTest, UnqualifiedId) { +TEST_P(SyntaxTreeTest, UnqualifiedIdIdentifier) { + EXPECT_TRUE(treeDumpEqual( ---------------- eduucaldas wrote: > It seems inappropriate to always repeat `UnqualfiiedId`, do you have any > other suggestion? Last commit change names to `TestSuite_TestCase` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D85819/new/ https://reviews.llvm.org/D85819 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits