Xiangling_L marked 7 inline comments as done. Xiangling_L added inline comments.
================ Comment at: llvm/include/llvm/CodeGen/AsmPrinter.h:466 + + bool preprocessStructorList(const DataLayout &DL, const Constant *List, + SmallVector<Structor, 8> &Structors); ---------------- jasonliu wrote: > A doxygen comment describe what this function does, and what its return value > means, and mention `Structors` is an output argument. > By looking at what this function does, it seems `buildStructorList` is a > better name. I meant to and should've named this function to `preprocessXXStructorList`, let me know if you still prefer `buildStructorList`. And if you do, since the underneath of `SmallVector` is a variable-sized array, maybe we should try `buildSortedStructorArray`? ================ Comment at: llvm/test/CodeGen/PowerPC/aix-static-init-key-object.ll:6 + +@llvm.global_ctors = appending global [1 x { i32, void ()*, i8* }] [{ i32, void ()*, i8* } { i32 65535, void ()* @foo, i8* @v}] + ---------------- jasonliu wrote: > Adding this test case would looks like we already decided how to handle .ref > in clang and llvm. But in fact, we haven't. I would prefer not having this > test. As we discussed offline, I would adjust the error message instead. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84534/new/ https://reviews.llvm.org/D84534 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits