vsavchenko added a comment. Other than parameter names, it looks totally reasonable to me.
================ Comment at: clang/lib/Analysis/HTMLPathDiagnosticConsumer.cpp:70 + const std::string &OutputDir, + const Preprocessor &pp, bool supportsMultipleFiles) : DiagOpts(std::move(DiagOpts)), Directory(OutputDir), PP(pp), ---------------- Maybe while we are here, we can change the names to match the code style (aka capitalize)? It seems like all other functions have similar problems. It's no biggie, but still... NOTE: I really wanted to try this new feature of Phabricator 😊 ================ Comment at: clang/lib/Analysis/PlistHTMLPathDiagnosticConsumer.cpp:25 + PathDiagnosticConsumerOptions DiagOpts, PathDiagnosticConsumers &C, + const std::string &prefix, const Preprocessor &PP, + const cross_tu::CrossTranslationUnitContext &CTU) { ---------------- As long as it is a new function, I guess we should definitely keep names according to the **Coding Standards** CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67422/new/ https://reviews.llvm.org/D67422 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits