Author: Nathan James Date: 2020-06-29T15:28:09+01:00 New Revision: 1f228e572da238c656958bf7f85b371d773eb588
URL: https://github.com/llvm/llvm-project/commit/1f228e572da238c656958bf7f85b371d773eb588 DIFF: https://github.com/llvm/llvm-project/commit/1f228e572da238c656958bf7f85b371d773eb588.diff LOG: [clang-tidy] Fix hicpp-named-paramater Currently this alias instantiates the readability-identifier-naming check, just swap it out to use the readability-named-paramater check. Reviewed By: aaron.ballman Differential Revision: https://reviews.llvm.org/D82711 Added: Modified: clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp Removed: ################################################################################ diff --git a/clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp b/clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp index ad367dcfed38..253c3893f0d4 100644 --- a/clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp +++ b/clang-tools-extra/clang-tidy/hicpp/HICPPTidyModule.cpp @@ -9,6 +9,7 @@ #include "../ClangTidy.h" #include "../ClangTidyModule.h" #include "../ClangTidyModuleRegistry.h" +#include "../bugprone/UndelegatedConstructorCheck.h" #include "../bugprone/UseAfterMoveCheck.h" #include "../cppcoreguidelines/AvoidGotoCheck.h" #include "../cppcoreguidelines/NoMallocCheck.h" @@ -20,7 +21,6 @@ #include "../google/ExplicitConstructorCheck.h" #include "../misc/NewDeleteOverloadsCheck.h" #include "../misc/StaticAssertCheck.h" -#include "../bugprone/UndelegatedConstructorCheck.h" #include "../modernize/AvoidCArraysCheck.h" #include "../modernize/DeprecatedHeadersCheck.h" #include "../modernize/UseAutoCheck.h" @@ -34,7 +34,7 @@ #include "../performance/NoexceptMoveConstructorCheck.h" #include "../readability/BracesAroundStatementsCheck.h" #include "../readability/FunctionSizeCheck.h" -#include "../readability/IdentifierNamingCheck.h" +#include "../readability/NamedParameterCheck.h" #include "../readability/UppercaseLiteralSuffixCheck.h" #include "ExceptionBaseclassCheck.h" #include "MultiwayPathsCoveredCheck.h" @@ -65,7 +65,7 @@ class HICPPModule : public ClangTidyModule { "hicpp-explicit-conversions"); CheckFactories.registerCheck<readability::FunctionSizeCheck>( "hicpp-function-size"); - CheckFactories.registerCheck<readability::IdentifierNamingCheck>( + CheckFactories.registerCheck<readability::NamedParameterCheck>( "hicpp-named-parameter"); CheckFactories.registerCheck<bugprone::UseAfterMoveCheck>( "hicpp-invalid-access-moved"); _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits