gribozavr2 accepted this revision. gribozavr2 marked an inline comment as done. gribozavr2 added inline comments.
================ Comment at: clang/include/clang/Tooling/Transformer/RewriteRule.h:44 +/// of `EditList`. +using EditList = MatchConsumer<llvm::SmallVector<Edit, 1>>; + ---------------- ymandel wrote: > gribozavr2 wrote: > > Could you explain the idea behind the word "list" in the name? I don't get > > it. > > > > Maybe "EditGenerator"? > It returns a list of edits. So, EditListGenerator is probably most precise, > but I wasn't sure that "generator" added much. I'm fine with any of the > names, EditGenerator probably being best (if we want Generator in the name) > because its concise while still aligning with multiple edits (since a > generator often can generate more than one item). WDYT? I suggested "generator" to make some indication that it is not a data structure that stores edits, but some precursor. `EditGenerator` SGTM. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D77419/new/ https://reviews.llvm.org/D77419 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits