sdesmalen accepted this revision. sdesmalen added a comment. This revision is now accepted and ready to land.
Thank you for this patch! Personally I find the code more readable without the SequentialType abstraction and the use of the GEP interface (getTypeAtIndex(Type, Idx)) you added in D75660 <https://reviews.llvm.org/D75660>. Like @nhaehnle I don't know whether this patch needs some more eyes before you commit this, but it looks good to me! ================ Comment at: llvm/lib/Transforms/IPO/GlobalOpt.cpp:442 +} +static uint64_t GetSRASequentialNumElements(Type *T) { + if (ArrayType *AT = cast<ArrayType>(T)) ---------------- nit: With only two uses, I'm not sure these functions make the code much more readable than just expanding it in their uses below. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75661/new/ https://reviews.llvm.org/D75661 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits