ABataev added inline comments.
================ Comment at: clang/lib/CodeGen/CGOpenMPRuntime.cpp:9244 +llvm::Function * +CGOpenMPRuntime::getUserDefinedMapperFunc(const OMPDeclareMapperDecl *D) { + auto I = UDMMap.find(D); ---------------- lildmh wrote: > ABataev wrote: > > `getOrEmitUserDefinedMapperFunc`? > I guess `getUserDefinedMapperFunc` is a better name? Because the user uses > this function to get the mapper function. Emitting a mapper function is a > side effect. I meant something like `getOrCreate...` but it is up to you. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67833/new/ https://reviews.llvm.org/D67833 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits