emankov added a comment. In D60220#1725633 <https://reviews.llvm.org/D60220#1725633>, @dim wrote:
> $ cat check-isnan.cpp > #include <math.h> > > int check_isnan(double d) > { > return ::__isnan(d); > } > $ clang -c check-isnan.cpp > Why can't the regular `isnan` be used instead? Or is this a CUDA-specific > requirement? (Apologies, but I know next to nothing about CUDA :) ) 1. `#include "cuda_runtime.h"` 2. as long as `__isnan` is a devide function, it should be called from `__devide__` or `__global__` function 3. `clang -c check-isnan.cpp -x cuda` Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D60220/new/ https://reviews.llvm.org/D60220 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits