NoQ accepted this revision. NoQ added a comment. This revision is now accepted and ready to land.
Fantastic, thanks!! ================ Comment at: clang/include/clang/StaticAnalyzer/Core/PathSensitive/CallEvent.h:259 /// calls. bool isCalled(const CallDescription &CD) const; ---------------- I don't fully understand how does overload resolution work in this case, maybe rename the original function? ================ Comment at: clang/lib/StaticAnalyzer/Checkers/MallocChecker.cpp:1006 const FunctionDecl *FD = C.getCalleeDecl(CE); - if (!FD) + if (!FD || FD->getKind() != Decl::Function) return; ---------------- The `FD->getKind() != Decl::Function` part is super mega redundant here. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68163/new/ https://reviews.llvm.org/D68163 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits