Szelethus added inline comments.
================ Comment at: cfe/trunk/lib/StaticAnalyzer/Checkers/DeadStoresChecker.cpp:133 std::unique_ptr<llvm::DenseSet<const VarDecl *>> InEH; + const bool WarnForDeadNestedAssignments; ---------------- NoQ wrote: > I suggest we adopt the idiom of passing the `Checker` object around and > asking it about its options instead of passing each option around separately. > This is easier and i don't see any downsides. Moreover, we already pass the > `Checker` around (just type-erased for no good reason). If you don't mind, > i'll remove this field as part of resolving merge conflicts in D65182. What about subcheckers? In any case, feel free to remove it for now. Repository: rL LLVM CHANGES SINCE LAST ACTION https://reviews.llvm.org/D66733/new/ https://reviews.llvm.org/D66733 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits