martong added a comment.

Looks good, I just have a comment about the matcher.



================
Comment at: clang/unittests/AST/ASTImporterTest.cpp:1434
 
+AST_MATCHER_P(RecordDecl, hasFieldIndirectFieldOrder, std::vector<StringRef>,
+              Order) {
----------------
This name sounds strange for me, perhaps `hasAnyKindOfFieldOrder` ?
Also, this matcher I think supersedes the `hasFieldOrder`, I mean in the tests 
where we use `hasFieldOrder` we could use this new matcher too, can't we? In 
that case, however, we can delete the old implementation.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D66866/new/

https://reviews.llvm.org/D66866



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to