JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land.
Two small suggestions for the test, but this change LGTM. ================ Comment at: clang/test/Driver/vfsmode.py:33 + new_name_len = target_len - len(absolute) - 1 + new_name_len = new_name_len if new_name_len < name_max else name_max + absolute = os.path.join(absolute, 'x' * new_name_len) ---------------- I like the Pythonic approach, but I wonder if `new_name_len = min(target_len - len(absolute) - 1, name_max)` wouldn't be easier to read. ================ Comment at: clang/test/Driver/vfsmode.py:48 +# exceed PATH_MAX. +assert os.path.exists(file_relative_path) + ---------------- Should we add an `assert not os.path.exists(absolute)` for good measure? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D65986/new/ https://reviews.llvm.org/D65986 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits