kpn added inline comments.
================ Comment at: include/llvm/IR/FPState.h:9-31 + enum FPModelKind { + FPM_Off, + FPM_Precise, + FPM_Strict, + FPM_Fast + }; + ---------------- lebedev.ri wrote: > All this needs comments, and possibly better names. > `FPM_Off`,etc is very non-self-explanatory. Shouldn't there be an "accept default" value? That way CreateConstrainedFAdd()/CreateConstrainedBinOp() can accept enumerations and avoid having front ends having to deal with MDNode*. Repository: rL LLVM CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62730/new/ https://reviews.llvm.org/D62730 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits