MaskRay added inline comments.
================ Comment at: clang/lib/Driver/ToolChains/Gnu.cpp:563 + crtend = Args.hasArg(options::OPT_shared) || IsPIE || IsStaticPIE ? + "crtend_shared" : "crtend"; + CmdArgs.push_back(ToolChain.getCompilerRTArgString( ---------------- phosek wrote: > MaskRay wrote: > > I believe `crtbegin.o` `crtend.o` should just work. It is not necessary to > > use `crtbegin_shared.o` `crtend_shared.o`. > This is related to your comments on D28791, specifically that we should be > using `crtbegin_shared.o` for `-shared` or `-pie` and `crtbegin.o` otherwise, > is that not the case? Yes. I think we can rename `crtbegin_shared.o` to `crtbegin.o` and use it for every configuration: `-no-pie` `-pie` `-shared` `-static` `-static -pie`. Repository: rC Clang CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59264/new/ https://reviews.llvm.org/D59264 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits