JonasToth added a comment. Thank you very much for working on this! See https://bugs.llvm.org/show_bug.cgi?id=34990 for the bug report, I mentionend this revision.
TBH i did not read through all the document, but scrolled mostly starting from 25%, it looks good to me. Given its length, what do you think about a short link-list at the beginning that will point to the section in the docs? With that its easier to see whats all handled by the check. ================ Comment at: docs/clang-tidy/checks/readability-identifier-naming.rst:9 +This check will try to enforce coding guidelines on the identifiers naming. It +supports one the following casing types and tries to convert from one to +another if a mismatch is detected ---------------- It supports one `of` the following, i think the `of` is missing? ================ Comment at: docs/clang-tidy/checks/readability-identifier-naming.rst:26 Many configuration options are available, in order to be able to create -different rules for different kind of identifier. In general, the -rules are falling back to a more generic rule if the specific case is not -configured. +different rules for different kinds of identifier. In general, the rules are +falling back to a more generic rule if the specific case is not configured. ---------------- `kinds of identifiers`? second 's' ================ Comment at: docs/clang-tidy/checks/readability-identifier-naming.rst:70 + public: + pre_abstract_class_post(); + }; ---------------- That would have been a change of the constructor name, the other examples don't have this behaviour, probably copy&paste artifact? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56563/new/ https://reviews.llvm.org/D56563 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits