alexfh accepted this revision. alexfh added a comment. This revision is now accepted and ready to land.
The patch looks good with one comment. I'll fix it and submit the patch for you. Thank you for working on this! ================ Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:548 @@ +547,3 @@ + } + + if (const auto *Loc = Result.Nodes.getNodeAs<TypeLoc>("typeLoc")) { ---------------- Note, that I suggested to use `Loc->getType()->getDecl()`, which uses `TypeLoc::getType()` and `Type::getDecl()`. http://reviews.llvm.org/D13081 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits