alexfh added a comment. Another couple of comments (fine for a follow-up).
================ Comment at: test/clang-tidy/readability-identifier-naming.cpp:72 @@ +71,3 @@ + +namespace FOO_NS { +// CHECK-MESSAGES: :[[@LINE-1]]:1: warning: invalid case style for namespace 'FOO_NS' [readability-identifier-naming] ---------------- Please add a test (with a CHECK-FIXES or a FIXME) for the usages of a namespace in qualified names (e.g. ::foo_ns::inline_namespace::my_enumeration). ================ Comment at: test/clang-tidy/readability-identifier-naming.cpp:209 @@ +208,3 @@ +// CHECK-FIXES: {{^}}class AAbstractClass {{{$}} + virtual ~abstract_class() = 0; + virtual void VIRTUAL_METHOD(); ---------------- Add a FIXME or a CHECK-FIXES for the class name in destructor. http://reviews.llvm.org/D10933 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits