tejohnson added inline comments. ================ Comment at: include/clang/Driver/Options.td:685 @@ -684,1 +684,3 @@ def fno_lto : Flag<["-"], "fno-lto">, Group<f_Group>; +def fthinlto : Flag<["-"], "fthinlto">, Flags<[CC1Option]>, Group<f_Group>; +def fno_thinlto : Flag<["-"], "fno-thinlto">, Group<f_Group>; ---------------- davidxl wrote: > spell it like "fthin-lto" seems better than one word "fthinlto" I considered that too, but wanted to distinguish from regular LTO. I could go either way.
================ Comment at: lib/CodeGen/BackendUtil.cpp:621 @@ -620,2 +620,3 @@ getPerModulePasses()->add( - createBitcodeWriterPass(*OS, CodeGenOpts.EmitLLVMUseLists)); + createBitcodeWriterPass(*OS, CodeGenOpts.EmitLLVMUseLists, + CodeGenOpts.EmitThinLTOIndex)); ---------------- davidxl wrote: > The change to this function is missing in the patch. Right, that is in LLVM and needs to be in a different patch (goes into a different repository). As mentioned in the patch summary this is dependent on LLVM patch http://reviews.llvm.org/D11907. http://reviews.llvm.org/D11908 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits