> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 21
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line21>
> >
> >     remove unused include

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 80
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line80>
> >
> >     iterators are mostly called it, not i.  The name i is used for an index.
> >

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 99
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line99>
> >
> >     magic numbers.  Besides, what is "viewMode content size height"?

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 107
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line107>
> >
> >     brace position
> >

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 108
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line108>
> >
> >     iterator = "it"

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 124
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line124>
> >
> >     iterator = "it"

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, line 146
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line146>
> >
> >     what color is this?  What is it used for?  Comments, please.

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoAnnotationLayoutManager.cpp, lines 164-166
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184269#file184269line164>
> >
> >      - spelling: connection, connectionPoint
> >      - Capital letter starting a sentence
> >

Fixed


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > libs/flake/KoShapeManager.h, line 209
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184272#file184272line209>
> >
> >     Why only annotation shape? This could be emitted for any shape that is 
> > removed.

My mean for now annotation just using it.


> On Aug. 27, 2013, 9 p.m., Inge Wallin wrote:
> > words/part/KWOdfWriter.cpp, lines 301-309
> > <http://git.reviewboard.kde.org/r/111914/diff/2/?file=184301#file184301line301>
> >
> >     It's time to do this now.

Fixed


- mojtaba


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/111914/#review38763
-----------------------------------------------------------


On Aug. 24, 2013, 5:38 a.m., Inge Wallin wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/111914/
> -----------------------------------------------------------
> 
> (Updated Aug. 24, 2013, 5:38 a.m.)
> 
> 
> Review request for Calligra.
> 
> 
> Description
> -------
> 
> This patch adds support for annotations to Words and Author. 
> 
> NOTE: We are aware that this patch is not yet ready for merge.  The review 
> request is as much for ourselves (ingwa, moji, boemann) as for others.
> 
> The patch is large and rather complex so we use the review board to get an 
> overview of the changes and to see early what we need to fix. There are still 
> a number of bugs and not 100% of the features that we want to support are 
> implemented.
> 
> All of this said, annotations basically work now and you can check out the 
> branch text-annotation if you want to test it. We would like to get some 
> feedback already now so we can fix the issues early and provide a cleaner 
> patch once we have finished the feature completely.
> 
> 
> Diffs
> -----
> 
>   ANNOTATIONS-ODF PRE-CREATION 
>   TODO-ANNOTATIONS PRE-CREATION 
>   libs/flake/CMakeLists.txt 7d03157 
>   libs/flake/KoAnnotationLayoutManager.h PRE-CREATION 
>   libs/flake/KoAnnotationLayoutManager.cpp PRE-CREATION 
>   libs/flake/KoShapeController.h 2ae03ca 
>   libs/flake/KoShapeController.cpp 817ba5e 
>   libs/flake/KoShapeManager.h 9df1671 
>   libs/flake/KoShapeManager.cpp 36666ce 
>   libs/kotext/KoAnnotation.h c4457fd 
>   libs/kotext/KoAnnotation.cpp e5a8a53 
>   libs/kotext/KoTextEditor.h 9fd3c05 
>   libs/kotext/KoTextEditor.cpp 40ac427 
>   libs/kotext/KoTextRangeManager.cpp fdde8ee 
>   libs/kotext/opendocument/KoTextLoader.cpp 7831109 
>   libs/textlayout/KoTextDocumentLayout.h a0fabcf 
>   libs/textlayout/KoTextDocumentLayout.cpp 1eec452 
>   plugins/textshape/AnnotationTextShape.h PRE-CREATION 
>   plugins/textshape/AnnotationTextShape.cpp PRE-CREATION 
>   plugins/textshape/AnnotationTextShapeFactory.h PRE-CREATION 
>   plugins/textshape/AnnotationTextShapeFactory.cpp PRE-CREATION 
>   plugins/textshape/CMakeLists.txt 1838cf1 
>   plugins/textshape/ReviewTool.h e2b8f95 
>   plugins/textshape/ReviewTool.cpp 53c87c7 
>   plugins/textshape/SimpleRootAreaProvider.cpp 30a74ab 
>   plugins/textshape/TextPlugin.cpp b99243f 
>   plugins/textshape/TextTool.cpp 0afc19f 
>   plugins/textshape/dialogs/SimpleAnnotationWidget.h PRE-CREATION 
>   plugins/textshape/dialogs/SimpleAnnotationWidget.cpp PRE-CREATION 
>   plugins/textshape/dialogs/SimpleAnnotationWidget.ui PRE-CREATION 
>   words/part/KWCanvas.cpp f33d993 
>   words/part/KWCanvasBase.h 31111ce 
>   words/part/KWCanvasBase.cpp 22d1c5f 
>   words/part/KWDocument.h 7654aa3 
>   words/part/KWDocument.cpp 259fd4e 
>   words/part/KWOdfSharedLoadingData.cpp 450b580 
>   words/part/KWOdfWriter.cpp 1675bf1 
>   words/part/KWView.h 517cbc1 
>   words/part/KWView.cpp 48265fd 
>   words/part/KWViewModeNormal.cpp 88e67b2 
>   words/part/frames/KWTextFrameSet.cpp 1bb513c 
>   words/part/words.rc 31cabbd 
> 
> Diff: http://git.reviewboard.kde.org/r/111914/diff/
> 
> 
> Testing
> -------
> 
> Created test files in LO with annotations and loaded them.  Also created our 
> own test files.
> 
> 
> Thanks,
> 
> Inge Wallin
> 
>

_______________________________________________
calligra-devel mailing list
calligra-devel@kde.org
https://mail.kde.org/mailman/listinfo/calligra-devel

Reply via email to