----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://git.reviewboard.kde.org/r/100918/#review2454 -----------------------------------------------------------
libs/kotext/styles/KoListLevelProperties.cpp <http://git.reviewboard.kde.org/r/100918/#comment2121> Sorry my fault. :) For 100 percent it's correct, but why do you ignore the relativeBulletSize = 0? Do we handle negative values? According to the spec: 18.3.23 percent (Positive or negative) percentage values in conformance with §5.9.11 of [XSL]. libs/odf/KoStyleStack.cpp <http://git.reviewboard.kde.org/r/100918/#comment2120> Let's make it more readable: when working with a percentage value, then do not divide and multiply it by 100. Bad example: qreal base = BASE; qreal percent = value.left(value.length() - 1).toDouble(); percent = percent / 100; return base * percent; //to get the value return percent * 100; //to get the percentage again Good example: qreal percent = value.left(value.length() - 1).toDouble(); return base * percent / 100; return percent; - Matus On March 24, 2011, 4:20 p.m., Gopalakrishna Bhat wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > http://git.reviewboard.kde.org/r/100918/ > ----------------------------------------------------------- > > (Updated March 24, 2011, 4:20 p.m.) > > > Review request for Calligra. > > > Summary > ------- > > Fixes the following problems in list rendering > 1)The type of list item was not shown in the paragraph > docker(SimpleParagraphWidget). > 2)Takes into account the font-size percent while loading and saving lists. > 3) Prefixes and suffixes are now displayed for bulleted lists. > > > This addresses bug 264143. > http://bugs.kde.org/show_bug.cgi?id=264143 > > > Diffs > ----- > > filters/words/oowriter/oowriterimport.cc 2bd55ee > libs/kotext/styles/KoCharacterStyle.h 3cec793 > libs/kotext/styles/KoCharacterStyle.cpp 6eaab0f > libs/kotext/styles/KoListLevelProperties.h 14814fe > libs/kotext/styles/KoListLevelProperties.cpp 62a5175 > libs/kotext/styles/KoListStyle.h bee4eaf > libs/kotext/styles/KoListStyle.cpp 52d7c2f > libs/odf/KoStyleStack.h 2f4d2cf > libs/odf/KoStyleStack.cpp 491f14e > plugins/textshape/ListItemsHelper.cpp aa61481 > plugins/textshape/TextShapeLayout.cpp ea49dc4 > plugins/textshape/commands/ChangeListCommand.cpp 23eeee0 > plugins/textshape/dialogs/ParagraphBulletsNumbers.cpp 14c5fd7 > plugins/textshape/tests/TestChangeListCommand.cpp 4da46d1 > plugins/textshape/tests/TestLists.cpp 316f5f6 > tools/mobile/ApplicationController.cpp 83ebe6e > words/part/KWDLoader.cpp e99435a > words/part/KWDocument.cpp 8408c42 > words/plugins/scripting/Style.h a72c0d2 > > Diff: http://git.reviewboard.kde.org/r/100918/diff > > > Testing > ------- > > > Thanks, > > Gopalakrishna > >
_______________________________________________ calligra-devel mailing list calligra-devel@kde.org https://mail.kde.org/mailman/listinfo/calligra-devel