Damien Zammit, le sam. 18 déc. 2021 17:08:47 +1100, a ecrit: > This disables the rump buffer cache and avoids any magic translation that > rump would do. > > * rumpdisk/block-rump.c (translate_name): Use `/dev/r%sd' format instead of > `/dev/%sd'.
Does this depend on the two previous patches? Does it depend on the newer rump source, or can it be used with the source currently in Debian? > --- > rumpdisk/block-rump.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/rumpdisk/block-rump.c b/rumpdisk/block-rump.c > index 8c29dc01..e4b890ac 100644 > --- a/rumpdisk/block-rump.c > +++ b/rumpdisk/block-rump.c > @@ -87,12 +87,12 @@ search_bd (char *name) > return NULL; > } > > -/* BSD name of whole disk device is /dev/wdXd > +/* BSD name of whole disk device is /dev/rwdXd > * but we will receive wdX as the name */ > static void > translate_name (char *output, int len, char *name) > { > - snprintf (output, len - 1, "/dev/%sd", name); > + snprintf (output, len - 1, "/dev/r%sd", name); > } > > static boolean_t > -- > 2.33.1