On Sat, Aug 11, 2012 at 07:42:27PM +0200, Richard Braun wrote: > On Fri, Aug 03, 2012 at 01:44:54PM -0700, Roland McGrath wrote: > > I can't really imagine what issue you have in mind. To fit with the > > convention in NPTL for extensions, it should be PTHREAD_CANCEL_POLLED_NP. > > (The "_NP" suffix indicates it's a non-POSIX feature.) > > What would you recommend we name the matching pthread_cond_wait-like > function ? Something like pthread_cond_poll_np ?
Or rather, should we make pthread_cond_wait return ECANCELED/EINTR as discussed ? -- Richard Braun
