Update of task #6200 (project hurd):
Wiki-like text discussion box: => There's a bit of
work to do both in the Hurd and glibc too, because of
GNU Mach's thread_get_state(i386_FLOAT_STATE) call.
- hurd/exec/elfcore.c:fetch_thread_fpregset(): in the core dump, fpx
state would probably be needed too.
- libc/sysdeps/mach/hurd/i386/trampoline.c:_hurd_setup_sighandler(): in
the sigcontext structure, fpx state would be useful too.
Both of these are not really _required_ for now, but we need to think
about the interface as soon as now.
Roland agreeded that thread_get_state(i386_FLOAT_STATE) mustn't be modified,
and that a new thread_get_state(i386_FLOAT_XSTATE) (or any better name)
should be defined instead.
_______________________________________________________
Reply to this item at:
<http://savannah.gnu.org/task/?6200>
_______________________________________________
Message posté via/par Savannah
http://savannah.gnu.org/
_______________________________________________
Bug-hurd mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/bug-hurd