Patch #309 has been updated. Project: Category: libihash Status: Open Summary: ihash rewrite
Follow-Ups: Date: Sun 08/17/2003 at 09:17 By: marcus Comment: I gave libihash a face lift, which includes the following: * All data types and functions put into the hurd_ namespace. * static initializer, and possibility to inline the struct hurd_ihash. * More data types for clarity. * Unsigned keys, to prevent overflow of signed data type. * Overwriting existing keys works correctly now. * Doesn't use even prime 2. I also changed all callers except pthread to use the inlined version of the hash, because it is the Right Thing to do. ------------------------------------------------------- Date: Wed 08/27/2003 at 23:10 By: marcus Comment: New version, which also has the following exciting features: * it works * maximum load, default 80% * quadratic probing * Doesn't require any memory for location pointers (all values must have the locp in the same offset, though) * iterator macro instead function with callback ------------------------------------------------------- ------------------------------------------------------- For more info, visit: http://savannah.gnu.org/patch/?func=detailpatch&patch_id=309&group_id=30 _______________________________________________ Message sent via/by Savannah http://savannah.gnu.org/ _______________________________________________ Bug-hurd mailing list [EMAIL PROTECTED] http://mail.gnu.org/mailman/listinfo/bug-hurd