Paul Eggert wrote: > > Btw, since you are renaming parameters 'int flag' to 'int flags', how > > about also renaming 'int dir' to 'int dirfd' ? > > I tend to avoid 'int dirfd', as that can cause confusion with the POSIX > dirfd function.
I see. Thanks for explaining. (But the dirfd function is from <dirent.h>, whereas the *at functions are from <sys/stat.h> or <unistd.h>, quite far away.) > So I've been using 'int dfd' instead. Perhaps rename to > that, when there's time and opportunity? Better not. I find 'dfd' a bit cryptic. Bruno
