Ondřej Bílka wrote: > +XALLOC_INLINE void * > +nmalloc (size_t n, size_t s) > +{ > + if (xalloc_oversized (n, s)) > + xalloc_die (); > + return xmalloc (n * s); > +}
This is the same as the existing xnmalloc, so why bother with a new name? Similarly for the other changes.