On 03/24/2012 09:28 PM, Gianluigi Tiesi wrote:
While compiling regex module one android I've discovered a problem
that on other 32bit compiler is only a warning
...
it's correct, but I think an ifdef may be used instead since
BITSET_WORD_BITS is a define
Generally speaking we prefer 'if (xxx)' to '#if xxx' where either will
do, because the former is easier to read and reason about. If the only
problem with 'if (xxx)' is a bogus warning by some random compiler then
it's probably better to leave it alone (and get the compiler fixed....).