On 01/11/12 15:24, Eric Blake wrote: > + best.len = 0; I have some qualms about adding unnecessary initializations merely to silence GCC. It's not just that it bloats the runtime -- it's that it makes the code more confusing, because later readers might mistakenly assume that the initializations are necessary, which might cause them to waste time trying to figure out why the initializations are there.
How about if we put that assignment inside an "#ifdef lint", or wrap it in IF_LINT, or something like that? That should make it clearer and avoid the runtime bloat.