Gary V. Vaughan wrote: > Hi Jim, ... >>> -# Override this in cfg.mk if you use a non-standard build-aux directory. >>> -build_aux ?= $(srcdir)/build-aux >>> +ifneq ($(build_aux),) >>> + $(error '*** set $$(_build-aux) relative to $$(srcdir) instead of >>> $$(build_aux)') >> >> That line is longer than 80. >> Please shorten or split it, and > > Done. > >> use a prefix of "$(ME): " as >> in most of the other diagnostics in this file. Or at least >> include $(ME) somewhere, so people know where it's coming from. > > $ fgrep '$(error ' ~/Devo/gnulib/top/* > top/maint.mk: $(error '*** set $$(_build-aux) relative to $$(srcdir) instead > of $$(build_aux)') > top/maint.mk: $(error '*** you need to > s/_prohibit_regexp/_sc_search_regexp/, and adapt') > > I changed the one error I added as requested, but I guess the other use which > I copied from needs to have $(ME) added too (and be wrapped to avoid breaking > the 80 column limit)?
You're welcome to change it if you'd like, but like your addition, that $(error ...) provoker is solely to alert people to a problem arising from a variable name change, and it's due to be removed in a few months: # _sc_search_regexp used to be named _prohibit_regexp. However, # upgrading to the new definition and leaving the old name undefined # would usually convert each custom rule using $(_prohibit_regexp) # (usually defined in cfg.mk) into a no-op. This definition ensures # that people know right away if they're still using the old name. # FIXME: remove in 2012. _prohibit_regexp = \ $(error '*** you need to s/_prohibit_regexp/_sc_search_regexp/, and adapt') Please add a similar FIXME comment (but with say "2013"), so we do eventually remove it. > Okay to push? Yes. Thanks.