Jim Meyering wrote: > > -#if MSVC_INVALID_PARAMETER_HANDLING == DEFAULT_HANDLING > > +#if HAVE_MSVC_INVALID_PARAMETER_HANDLER \ > > + && MSVC_INVALID_PARAMETER_HANDLING == DEFAULT_HANDLING > > gl_msvc_inval_ensure_handler (); > > #endif > > That is a detail specific to MSVC. Why impose the readability and > maintenance hassle of requiring such an expression on all callers?
It's not for all callers. It's only for specific tests. I could introduce a macro MSVC_INIT_INVALID_PARAMETER_HANDLER_FOR_TESTS_WITH_FUNCTIONS_WITHOUT_GNULIB_WORKAROUND() but that would be so special-purpose that I really wonder whether it's worth adding to msvc-inval.h. Bruno