Hello,

* Paul Eggert wrote on Tue, May 24, 2011 at 07:28:36AM CEST:
> Come to think of it, it'd be even easier to read this way:
> 
>   sed_extract_condition2='
>     /^ *'"$escaped_dep"' *\[.*\] *$/{
>       s/^ *'"$escaped_dep"' *\[\(.*\)\] *$/\1/p
>     }
>   '

It's even easier to read this way IMVHO (and just as portable):

  sed_extract_condition2='
    /^ *'"$escaped_dep"' *\[\(.*\)\] *$/ s//\1/p
  '

Cheers,
Ralf

Reply via email to