Jim Meyering wrote: > David Bartley wrote: >> The following patches for coreutils and gnulib add a new Solaris 10 >> privilege module as previously suggested [1]. > > Hi David, > > Thanks for following through. > Are you up to the task of making a few more changes? > > ============================================================ > - naming: the module and function names should be OS-agnostic, > in case some day we extend it to other than Solaris 10. > For example, I'll bet they already work on opensolaris. > Maybe something like priv-set.[ch] for module/file names > and priv_set_* for function names. > By the say, with git, you can perform the requested renaming > trivially via this trick: > Take your git format-patch output (what you mailed to this list), > and perform the global substitutions: > > perl -pe 's/sol10priv_/priv_set_/g;s/sol10priv.([chm])/priv-set.$1/g;' > -e s/sol10priv/priv_set/g FILE > FILE-new > > Then apply that patch on a new branch like this: > > git co master > git co -b new > git am FILE-new
To be complete, I have to say that "co" is an alias for checkout. I have this in ~/.gitconfig: [alias] st = status co = checkout ci = commit br = branch desc = describe fp = format-patch syncsub = submodule foreach git pull origin master